$re = '/^(?:(?<protocol>[^:/]+:))?(?::?\/\/)?(?:(?<user>[^/:]*)(?::(?<passwd>[^@]*))?@)?(?:(?<host>[\w._-]*))?(?::(?<port>\d*))?(?:(?<path>\/?[^?]*))?(?:(?<search>\?[^#]*))?(?:(?<hash>#.*))?$/';
$str = 'https://user:pwd@localhost:6677/path/to/a/index.html?k1=v1&k2=v2#12313456';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);