#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?:(?<protocol>[^:/]+:))?(?::?\/\/)?(?:(?<user>[^/:]*)(?::(?<passwd>[^@]*))?@)?(?:(?<host>[\w._-]*))?(?::(?<port>\d*))?(?:(?<path>\/?[^?]*))?(?:(?<search>\?[^#]*))?(?:(?<hash>#.*))?$"
Local $sString = "https://user:pwd@localhost:6677/path/to/a/index.html?k1=v1&k2=v2#12313456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")