import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?<protocol>[^:/]+:))?(?::?\\/\\/)?(?:(?<user>[^/:]*)(?::(?<passwd>[^@]*))?@)?(?:(?<host>[\\w._-]*))?(?::(?<port>\\d*))?(?:(?<path>\\/?[^?]*))?(?:(?<search>\\?[^#]*))?(?:(?<hash>#.*))?$";
final String string = "https://user:pwd@localhost:6677/path/to/a/index.html?k1=v1&k2=v2#12313456";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}