$re = '/^(1[012]|[1-9]):[0-5][0-9](\s)?([aAP][mM])$/';
$str = '12:00 AM';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);