const regex = /^(1[012]|[1-9]):[0-5][0-9](\s)?([aAP][mM])$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(1[012]|[1-9]):[0-5][0-9](\\s)?([aAP][mM])$', '')
const str = `12:00 AM`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}