using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(1[012]|[1-9]):[0-5][0-9](\s)?([aAP][mM])$";
string input = @"12:00 AM";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}