package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(1[012]|[1-9]):[0-5][0-9](\s)?([aAP][mM])$`)
var str = `12:00 AM`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}