$re = '/(?<=\w{7}\s\[)[^\]]+/m';
$str = ' fifthrelease 566091c changes to labranges] (3rd revision) loaded
firstrelease 4a56940 [origin/firstrelease] change priority to 1100 for all OpenQuery DVPs
fourthrelease 2875c7b [origin/fourthrelease] all DVPs loaded (including new formulas); rev 21 CRF
main 566091c [origin/main] changes to labranges (3rd revision) loaded
secondrelease ff35618 [origin/secondrelease] fixed double SAE mail generated by AE_09
* sixthrelease 440478f [origin/sixthrelease] 4th lab revision processed and loaded
thirdrelease e3d7038 [origin/thirdrelease] LabRanges loaded';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);