use strict;
my $str = ' fifthrelease 566091c changes to labranges] (3rd revision) loaded
firstrelease 4a56940 [origin/firstrelease] change priority to 1100 for all OpenQuery DVPs
fourthrelease 2875c7b [origin/fourthrelease] all DVPs loaded (including new formulas); rev 21 CRF
main 566091c [origin/main] changes to labranges (3rd revision) loaded
secondrelease ff35618 [origin/secondrelease] fixed double SAE mail generated by AE_09
* sixthrelease 440478f [origin/sixthrelease] 4th lab revision processed and loaded
thirdrelease e3d7038 [origin/thirdrelease] LabRanges loaded';
my $regex = qr/(?<=\w{7}\s\[)[^\]]+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}