import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\w{7}\\s\\[)[^\\]]+";
final String string = " fifthrelease 566091c changes to labranges] (3rd revision) loaded\n"
+ " firstrelease 4a56940 [origin/firstrelease] change priority to 1100 for all OpenQuery DVPs\n"
+ " fourthrelease 2875c7b [origin/fourthrelease] all DVPs loaded (including new formulas); rev 21 CRF\n"
+ " main 566091c [origin/main] changes to labranges (3rd revision) loaded\n"
+ " secondrelease ff35618 [origin/secondrelease] fixed double SAE mail generated by AE_09\n"
+ "* sixthrelease 440478f [origin/sixthrelease] 4th lab revision processed and loaded\n"
+ " thirdrelease e3d7038 [origin/thirdrelease] LabRanges loaded";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}