const regex = /(?<=\w{7}\s\[)[^\]]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\w{7}\\s\\[)[^\\]]+', 'gm')
const str = ` fifthrelease 566091c changes to labranges] (3rd revision) loaded
firstrelease 4a56940 [origin/firstrelease] change priority to 1100 for all OpenQuery DVPs
fourthrelease 2875c7b [origin/fourthrelease] all DVPs loaded (including new formulas); rev 21 CRF
main 566091c [origin/main] changes to labranges (3rd revision) loaded
secondrelease ff35618 [origin/secondrelease] fixed double SAE mail generated by AE_09
* sixthrelease 440478f [origin/sixthrelease] 4th lab revision processed and loaded
thirdrelease e3d7038 [origin/thirdrelease] LabRanges loaded`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}