$re = '/([\w]+);([\d]{2})-([\w]{3}|[\d]{2})-([\d]{4});([\d]{2}):([\d]{2}):([\d]{2});([\d]+);(?(?=[\w]*;)([\w]*);|)((?:([a-zA-Z0-9_@.#\/&+\(\)\-\\\\!$%^*=\',.<>?{}\[\]`~:\| ]+)[ ]*[-][ ]*([\d]*);)+)([\d]+);/';
$str = 'SGH;02-FEB-2017;02:02:02;200;buah -1;3;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);