using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w]+);([\d]{2})-([\w]{3}|[\d]{2})-([\d]{4});([\d]{2}):([\d]{2}):([\d]{2});([\d]+);(?(?=[\w]*;)([\w]*);|)((?:([a-zA-Z0-9_@.#\/&+\(\)\-\\!$%^*=',.<>?{}\[\]`~:\| ]+)[ ]*[-][ ]*([\d]*);)+)([\d]+);";
string input = @"SGH;02-FEB-2017;02:02:02;200;buah -1;3;";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}