use strict;
my $str = 'SGH;02-FEB-2017;02:02:02;200;buah -1;3;';
my $regex = qr/([\w]+);([\d]{2})-([\w]{3}|[\d]{2})-([\d]{4});([\d]{2}):([\d]{2}):([\d]{2});([\d]+);(?(?=[\w]*;)([\w]*);|)((?:([a-zA-Z0-9_@.#\/&+\(\)\-\\!$%^*=',.<>?{}\[\]`~:\| ]+)[ ]*[-][ ]*([\d]*);)+)([\d]+);/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}