const regex = /([\w]+);([\d]{2})-([\w]{3}|[\d]{2})-([\d]{4});([\d]{2}):([\d]{2}):([\d]{2});([\d]+);(?(?=[\w]*;)([\w]*);|)((?:([a-zA-Z0-9_@.#\/&+\(\)\-\\!$%^*=',.<>?{}\[\]`~:\| ]+)[ ]*[-][ ]*([\d]*);)+)([\d]+);/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\w]+);([\\d]{2})-([\\w]{3}|[\\d]{2})-([\\d]{4});([\\d]{2}):([\\d]{2}):([\\d]{2});([\\d]+);(?(?=[\\w]*;)([\\w]*);|)((?:([a-zA-Z0-9_@.#\\\/&+\\(\\)\\-\\\\!$%^*=\',.<>?{}\\[\\]`~:\\| ]+)[ ]*[-][ ]*([\\d]*);)+)([\\d]+);', 'g')
const str = `SGH;02-FEB-2017;02:02:02;200;buah -1;3;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}