import Foundation
let pattern = #"\b([a-zA-Z0-9-._]+)@[a-zA-Z0-9-]+(\.[a-zA-Z0-9]{2,})+\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
name.surname@gmail.com
anonymous123@yahoo.co.uk
my_email@outlook.co
johnsnow@gmail
anonymous123@...uk
myemail@outlook.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)