import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b([a-zA-Z0-9-._]+)@[a-zA-Z0-9-]+(\\.[a-zA-Z0-9]{2,})+\\b";
final String string = "name.surname@gmail.com\n"
+ "anonymous123@yahoo.co.uk\n"
+ "my_email@outlook.co\n"
+ "johnsnow@gmail\n"
+ "anonymous123@...uk\n"
+ "myemail@outlook.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}