#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b([a-zA-Z0-9-._]+)@[a-zA-Z0-9-]+(\.[a-zA-Z0-9]{2,})+\b"
Local $sString = "name.surname@gmail.com" & @CRLF & _
"anonymous123@yahoo.co.uk" & @CRLF & _
"my_email@outlook.co" & @CRLF & _
"johnsnow@gmail" & @CRLF & _
"anonymous123@...uk" & @CRLF & _
"myemail@outlook."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")