// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b([a-zA-Z0-9-._]+)@[a-zA-Z0-9-]+(\.[a-zA-Z0-9]{2,})+\b").unwrap();
let string = "name.surname@gmail.com
anonymous123@yahoo.co.uk
my_email@outlook.co
johnsnow@gmail
anonymous123@...uk
myemail@outlook.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}