import Foundation
let pattern = #"(?:(?:(?:<([^ ]+)(?:.*)>)\[\[(?:<\/\1>))|(?:\[\[))(?:(?:(?:<([^ ]+)(?:.*)>)(.+?)(?:<\/\2>))|(.+?))(?:(?:(?:<([^ ]+)(?:.*)>)\]\](?:<\/\5>))|(?:\]\]))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[[plain wikilinks]]
<e>[[</e>first tag]]
<e dsss>[[</e>meta on first tag]]
<e dsss>[[</e><div>first tag + meta + container</div>]]
<e dsss>[[</e><div>first tag + meta + container + third tag</div><div>]]</div>
<e dsss>[[</e>forgot a bracket
<e dsss>[[</e>bracket containers<e>]]</e>
all is well
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$3$4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)