#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:(?:(?:<([^ ]+)(?:.*)>)\[\[(?:<\/\1>))|(?:\[\[))(?:(?:(?:<([^ ]+)(?:.*)>)(.+?)(?:<\/\2>))|(.+?))(?:(?:(?:<([^ ]+)(?:.*)>)\]\](?:<\/\5>))|(?:\]\]))"
Local $sString = "[[plain wikilinks]]" & @CRLF & _
"<e>[[</e>first tag]]" & @CRLF & _
"<e dsss>[[</e>meta on first tag]]" & @CRLF & _
"<e dsss>[[</e><div>first tag + meta + container</div>]]" & @CRLF & _
"<e dsss>[[</e><div>first tag + meta + container + third tag</div><div>]]</div>" & @CRLF & _
"<e dsss>[[</e>forgot a bracket" & @CRLF & _
"<e dsss>[[</e>bracket containers<e>]]</e>" & @CRLF & _
"all is well"
Local $sSubst = "$3$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)