$re = '/(?:(?:(?:<([^ ]+)(?:.*)>)\[\[(?:<\/\1>))|(?:\[\[))(?:(?:(?:<([^ ]+)(?:.*)>)(.+?)(?:<\/\2>))|(.+?))(?:(?:(?:<([^ ]+)(?:.*)>)\]\](?:<\/\5>))|(?:\]\]))/m';
$str = '[[plain wikilinks]]
<e>[[</e>first tag]]
<e dsss>[[</e>meta on first tag]]
<e dsss>[[</e><div>first tag + meta + container</div>]]
<e dsss>[[</e><div>first tag + meta + container + third tag</div><div>]]</div>
<e dsss>[[</e>forgot a bracket
<e dsss>[[</e>bracket containers<e>]]</e>
all is well';
$subst = "$3$4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;