const regex = /(?:(?:(?:<([^ ]+)(?:.*)>)\[\[(?:<\/\1>))|(?:\[\[))(?:(?:(?:<([^ ]+)(?:.*)>)(.+?)(?:<\/\2>))|(.+?))(?:(?:(?:<([^ ]+)(?:.*)>)\]\](?:<\/\5>))|(?:\]\]))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:(?:<([^ ]+)(?:.*)>)\\[\\[(?:<\\\/\\1>))|(?:\\[\\[))(?:(?:(?:<([^ ]+)(?:.*)>)(.+?)(?:<\\\/\\2>))|(.+?))(?:(?:(?:<([^ ]+)(?:.*)>)\\]\\](?:<\\\/\\5>))|(?:\\]\\]))', 'gm')
const str = `[[plain wikilinks]]
<e>[[</e>first tag]]
<e dsss>[[</e>meta on first tag]]
<e dsss>[[</e><div>first tag + meta + container</div>]]
<e dsss>[[</e><div>first tag + meta + container + third tag</div><div>]]</div>
<e dsss>[[</e>forgot a bracket
<e dsss>[[</e>bracket containers<e>]]</e>
all is well`;
const subst = `$3$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);