import Foundation
let pattern = #"(?i)(least|most) significant decimal (\(X+\s?\.\s?X+\))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Beep; Least Significant Decimal (XX . X);
Beep; Least Significant Decimal (XX . X); Numeric;
Beep; Least Significant Decimal (XX . X); System Beep;
Beep; Most Significant Decimal (X . XX);
Beep; Most Significant Decimal (X . XX); Numeric;
Beep; No Decimal;
Beep; No Decimal; Numeric;
Beep; No Decimal; Numeric; System Beep;
Beep; Numeric;
Beep; System Beep;
Leading zeroes; Least Significant Decimal (XX . X); Numeric;
Leading zeroes; No Decimal; Numeric;
Leading zeroes; Numeric;
Least Significant Decimal (XX . X);
Least Significant Decimal (XX . X); Numeric;
Least Significant Decimal (XX . X); Numeric; System Beep;
Least Significant Decimal (XX.X)
Most Significant Decimal (X . XX);
Most Significant Decimal (X . XX); Most Significant Decimal (X . XX); Numeric; Numeric;
Most Significant Decimal (X . XX); Numeric;
Most Significant Decimal (X . XX); Numeric; System Beep;
Most Significant Decimal (X.XX)
Most significant decimal (X . XX); Numeric;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)