# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)(least|most) significant decimal (\(X+\s?\.\s?X+\))"
test_str = ("Beep; Least Significant Decimal (XX . X);\n"
"Beep; Least Significant Decimal (XX . X); Numeric;\n"
"Beep; Least Significant Decimal (XX . X); System Beep;\n"
"Beep; Most Significant Decimal (X . XX);\n"
"Beep; Most Significant Decimal (X . XX); Numeric;\n"
"Beep; No Decimal;\n"
"Beep; No Decimal; Numeric;\n"
"Beep; No Decimal; Numeric; System Beep;\n"
"Beep; Numeric;\n"
"Beep; System Beep;\n"
"Leading zeroes; Least Significant Decimal (XX . X); Numeric;\n"
"Leading zeroes; No Decimal; Numeric;\n"
"Leading zeroes; Numeric;\n"
"Least Significant Decimal (XX . X);\n"
"Least Significant Decimal (XX . X); Numeric;\n"
"Least Significant Decimal (XX . X); Numeric; System Beep;\n"
"Least Significant Decimal (XX.X)\n"
"Most Significant Decimal (X . XX);\n"
"Most Significant Decimal (X . XX); Most Significant Decimal (X . XX); Numeric; Numeric;\n"
"Most Significant Decimal (X . XX); Numeric;\n"
"Most Significant Decimal (X . XX); Numeric; System Beep;\n"
"Most Significant Decimal (X.XX)\n"
"Most significant decimal (X . XX); Numeric;\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.