#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(least|most) significant decimal (\(X+\s?\.\s?X+\))"
Local $sString = "Beep; Least Significant Decimal (XX . X);" & @CRLF & _
"Beep; Least Significant Decimal (XX . X); Numeric;" & @CRLF & _
"Beep; Least Significant Decimal (XX . X); System Beep;" & @CRLF & _
"Beep; Most Significant Decimal (X . XX);" & @CRLF & _
"Beep; Most Significant Decimal (X . XX); Numeric;" & @CRLF & _
"Beep; No Decimal;" & @CRLF & _
"Beep; No Decimal; Numeric;" & @CRLF & _
"Beep; No Decimal; Numeric; System Beep;" & @CRLF & _
"Beep; Numeric;" & @CRLF & _
"Beep; System Beep;" & @CRLF & _
"Leading zeroes; Least Significant Decimal (XX . X); Numeric;" & @CRLF & _
"Leading zeroes; No Decimal; Numeric;" & @CRLF & _
"Leading zeroes; Numeric;" & @CRLF & _
"Least Significant Decimal (XX . X);" & @CRLF & _
"Least Significant Decimal (XX . X); Numeric;" & @CRLF & _
"Least Significant Decimal (XX . X); Numeric; System Beep;" & @CRLF & _
"Least Significant Decimal (XX.X)" & @CRLF & _
"Most Significant Decimal (X . XX);" & @CRLF & _
"Most Significant Decimal (X . XX); Most Significant Decimal (X . XX); Numeric; Numeric;" & @CRLF & _
"Most Significant Decimal (X . XX); Numeric;" & @CRLF & _
"Most Significant Decimal (X . XX); Numeric; System Beep;" & @CRLF & _
"Most Significant Decimal (X.XX)" & @CRLF & _
"Most significant decimal (X . XX); Numeric;" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")