// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?imux)^(?<username>\w+)\.(?<group>\w+)(\@masaged\.com)*").unwrap();
let string = "emad.durab@masaged.com
ahemd.ests
عماد.ابوغالي
emad@abc.com
Salem.dearME@masaged.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}