using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<username>\w+)\.(?<group>\w+)(\@masaged\.com)*";
string input = @"emad.durab@masaged.com
ahemd.ests
عماد.ابوغالي
emad@abc.com
Salem.dearME@masaged.com
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline | RegexOptions.CultureInvariant | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}