$re = '/^(?<username>\w+)\.(?<group>\w+)(\@masaged\.com)*/imux';
$str = 'emad.durab@masaged.com
ahemd.ests
عماد.ابوغالي
emad@abc.com
Salem.dearME@masaged.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);