#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?imux)^(?<username>\w+)\.(?<group>\w+)(\@masaged\.com)*"
Local $sString = "emad.durab@masaged.com" & @CRLF & _
"ahemd.ests" & @CRLF & _
"عماد.ابوغالي" & @CRLF & _
"emad@abc.com" & @CRLF & _
"Salem.dearME@masaged.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")