$re = '/<ort>(.*?)<\/ort>/';
$str = '<ort>München</ort><strasse>Hauptstr.</strasse><ort>Dortmund</ort>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);