$re = '/_(B|T)\-{2,4}\d{4}$/m';
$str = '123456_B--7545
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;