# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/_(B|T)\-{2,4}\d{4}$//gm;t' <<< "123456_B--7545
"