const regex = /_(B|T)\-{2,4}\d{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('_(B|T)\\-{2,4}\\d{4}$', 'gm')
const str = `123456_B--7545
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);