package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)_(B|T)\-{2,4}\d{4}$`)
var str = `123456_B--7545
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}