import Foundation
let pattern = ##"""
# Adding password requirements are as easy as tacking on
# another (?=...) group.
^
(?=(?:[^a-z]*[a-z]){1}) # At least {1} lowercase 'a-z' letter
(?=(?:[^A-Z]*[A-Z]){2}) # At least {2} uppercase 'A-Z' letters
(?=(?:[^0-9]*[0-9]){3}) # At least {3} digits
(?=(?:[^\s]*[\s]){1}) # At least {1} whitespace
(?=(?:[^[:punct:]]*[[:punct:]]){1}) # At least {1} special char
(?=.{9}) # A minimum of 9 characters
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
See 'unit tests' to see all matching/non-matching examples.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)