// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)# Adding password requirements are as easy as tacking on
# another (?=...) group.
^
(?=(?:[^a-z]*[a-z]){1}) # At least {1} lowercase 'a-z' letter
(?=(?:[^A-Z]*[A-Z]){2}) # At least {2} uppercase 'A-Z' letters
(?=(?:[^0-9]*[0-9]){3}) # At least {3} digits
(?=(?:[^\s]*[\s]){1}) # At least {1} whitespace
(?=(?:[^[:punct:]]*[[:punct:]]){1}) # At least {1} special char
(?=.{9}) # A minimum of 9 characters
").unwrap();
let string = "See 'unit tests' to see all matching/non-matching examples.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}