import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "# Adding password requirements are as easy as tacking on\n"
+ "# another (?=...) group.\n"
+ "^\n"
+ "(?=(?:[^a-z]*[a-z]){1}) # At least {1} lowercase 'a-z' letter\n"
+ "(?=(?:[^A-Z]*[A-Z]){2}) # At least {2} uppercase 'A-Z' letters\n"
+ "(?=(?:[^0-9]*[0-9]){3}) # At least {3} digits\n"
+ "(?=(?:[^\\s]*[\\s]){1}) # At least {1} whitespace\n"
+ "(?=(?:[^[:punct:]]*[[:punct:]]){1}) # At least {1} special char\n"
+ "(?=.{9}) # A minimum of 9 characters\n";
final String string = "See 'unit tests' to see all matching/non-matching examples.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}