re = /# Adding password requirements are as easy as tacking on
# another (?=...) group.
^
(?=(?:[^a-z]*[a-z]){1}) # At least {1} lowercase 'a-z' letter
(?=(?:[^A-Z]*[A-Z]){2}) # At least {2} uppercase 'A-Z' letters
(?=(?:[^0-9]*[0-9]){3}) # At least {3} digits
(?=(?:[^\s]*[\s]){1}) # At least {1} whitespace
(?=(?:[^[:punct:]]*[[:punct:]]){1}) # At least {1} special char
(?=.{9}) # A minimum of 9 characters
/mx
str = 'See \'unit tests\' to see all matching/non-matching examples.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end