use strict;
my $str = 'assignment_group: 1a29e044a527e100cd783922e1e94efb
short_description: Short text .....goes here
description: Long text goes here, line 1
and here is line 2
and line 3
right until the end - line 4
';
my $regex = qr/\ndescription:\s*([^]*)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}