import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\ndescription:\\s*([^]*)";
final String string = "assignment_group: 1a29e044a527e100cd783922e1e94efb\n"
+ "short_description: Short text .....goes here\n"
+ "description: Long text goes here, line 1\n"
+ "and here is line 2\n"
+ "and line 3\n"
+ "right until the end - line 4\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}