using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\ndescription:\s*([^]*)";
string input = @"assignment_group: 1a29e044a527e100cd783922e1e94efb
short_description: Short text .....goes here
description: Long text goes here, line 1
and here is line 2
and line 3
right until the end - line 4
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}