const regex = /\ndescription:\s*([^]*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\ndescription:\\s*([^]*)', '')
const str = `assignment_group: 1a29e044a527e100cd783922e1e94efb
short_description: Short text .....goes here
description: Long text goes here, line 1
and here is line 2
and line 3
right until the end - line 4
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}