re = /^((?!-([ABC])(\d{3})).)*$/m
str = '02731043-V2024
02731043*-V2024
02731043*-I2024
3423432fffetertetg02731043*-V2024
02731043
02731043*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end