$re = '/^((?!-([ABC])(\d{3})).)*$/m';
$str = '02731043-V2024
02731043*-V2024
02731043*-I2024
3423432fffetertetg02731043*-V2024
02731043
02731043*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);