using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!-([ABC])(\d{3})).)*$";
string input = @"02731043-V2024
02731043*-V2024
02731043*-I2024
3423432fffetertetg02731043*-V2024
02731043
02731043*";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}