import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?!-([ABC])(\\d{3})).)*$";
final String string = "02731043-V2024\n"
+ "02731043*-V2024\n"
+ "02731043*-I2024\n"
+ "3423432fffetertetg02731043*-V2024\n"
+ "02731043\n"
+ "02731043*";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}