import Foundation
let pattern = #"\w*_\d{1}\.\d{1}\.zip"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
IDG_COM_UR_PREV_CLT_0.1.zip
IDG_COM_UR_PREV_CLT_0.2.zip
IDG_COM_UR_TEST_0.1.zip
IDG_COM_UR_TEST_0.2.zip
IDG_COM_UR_TEST_TEST_TEST_TEST_TEST_0.1.zip
IDG_COM_UR_TEST_TEST_TEST_TEST_0.2.zip
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)