package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w*_\d{1}\.\d{1}\.zip`)
var str = `IDG_COM_UR_PREV_CLT_0.1.zip
IDG_COM_UR_PREV_CLT_0.2.zip
IDG_COM_UR_TEST_0.1.zip
IDG_COM_UR_TEST_0.2.zip
IDG_COM_UR_TEST_TEST_TEST_TEST_TEST_0.1.zip
IDG_COM_UR_TEST_TEST_TEST_TEST_0.2.zip`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}