re = /\w*_\d{1}\.\d{1}\.zip/m
str = 'IDG_COM_UR_PREV_CLT_0.1.zip
IDG_COM_UR_PREV_CLT_0.2.zip
IDG_COM_UR_TEST_0.1.zip
IDG_COM_UR_TEST_0.2.zip
IDG_COM_UR_TEST_TEST_TEST_TEST_TEST_0.1.zip
IDG_COM_UR_TEST_TEST_TEST_TEST_0.2.zip'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end